Jump to content


Dennisbeechie

Member Since 11 Dec 2016
Offline Last Active Private
-----

Topics I've Started

Underhood lighting

19 March 2017 - 07:46 PM

I dont know if this is the right place for this... But anyways, I thought I'd put some leds under the hood in my 521 to replace the tiny halogen bulb in there, I think its a little too bright lol but I like it. I like it a lot.20170319_190238_zpsh1lwmsv0.jpg20170319_190257_zps3cwwoxxz.jpg20170319_203149_zpsk5it3x6j.jpg20170319_203202_zpsjqs66jzm.jpg
In doing so I looked up and found some notes in the dust on the hood, kinda random but I thought it was funny, pretty genius really...20170319_191759_zps826twi9x.jpg

1970 Datsun 521 L20b running rough.

20 February 2017 - 05:13 PM

This truck has been a pain in my ass from the get go. The issue I'm having seems to be progressively getting worse. When I first got it, it idles fine and and drove decent, unless I hammered on the gas then it would bog down and back fire. It has a Empi 32/36 electric choke carb. I have adjusted timing to 12 degrees, new plugs, new cap and rotor, points and condenser seem in good shape, adjusted the fuel/air screw, put a fuel regulator on it, seafoam in the gas tank and oil, new glass fuel filter, rebuild kit on the carb (new gaskets, o rings, accel pump). Now it idles ok but if I give it any gas it bogs down, if I put it in gear and go down the road, I can get through 1st 2nd slowly giving it gas and when I get to third it wants to stall and die, I have to shift all the way back to first and feather it back home, then when its parked it runs fine again. I'm at a loss I hope someone can give me some ideas on what to look for. It sat overnight and I went to start it up after that short drive down the road and back it would not start, no spark at the coil. I cleaned/tightened any contacts going to the coil, ballast resistor, distributor, and magically got spark again but the same issue with it bogging down. I'm thinking maybe the float needs adjusted or new points and condenser, maybe the jets are too big? Too little? Idk. I got this truck to learn how to do these things, and its definitely a perfect learning experience. Thanks for your time guys and sorry for rambling.

Refinished instrument cluster

19 January 2017 - 08:05 PM

Hey ratsun folks, I just thought I would throw this out there for you to look at maybe come up with some ideas or whatever. Only 1 or 2 of my gauge bulbs were working in my 521 so I pulled the gauges out to see if it was maybe something else and ordered new led bulbs. All of the pins for the wiring plug were a little loose so I fixed those with some solder. The chrome bezel was rusted and pitted so I sanded primed and painted it blue. The needles for the gauges were faded, used my wife's bright red nail polish and put 3 coats on the needles. Since it was all taken apart I decided I might as well paint the grey as it also was a little faded. The bulbs came in so I popped out the little green dome light covers and installed the lights. Also the blinker indicators were originally a thick material I took that out and glue in some thin blue plastic. I'm thinking my voltage regulator is no good? Neither the temp or fuel gauges are working at the moment 😖 anyways Here's a couple pics!
IMG_19891_zpscvjscvxv.jpg here's a before shot
20161231_191607_HDR_zps7bj0yyld.jpg
And an after pic...
20170116_184951_zpspi00wfm8.jpg
And with the lights on

1970 Datsun 521

15 January 2017 - 07:59 PM

Hello members, new to the Datsun community just wanted to check in and say Hi! I have a 1970 Datsun 521 that I recently got and plan to have a little fun with. I'm curious how to post pictures on here so I can share progress and stuff, thanks a lot ratsun!