Jump to content


d.p

Member Since 11 Nov 2016
Offline Last Active Today, 06:14 PM
-----

Topics I've Started

Manual choke cable? 71 521

01 November 2017 - 06:09 AM

Anyone gone from that twisted to a single wire?  Mine is frayed and every time I disengage from my weber it frays even more.  Its hard to pull and clicks when I push it back so I figure I might as well replace it.  Wondering what my options are?


Broken timing cover dizzy mount

20 October 2017 - 06:44 AM

Hits keep coming with this truck.  

 

Was taking a look today and noticed my dizzy mount on the timing cover had cracked.  Took the dizzy out and the section seems to have just sheered off.  Just recently I installed a petronix dizzy but not sure that would cause this?  I have another L16 with the timing cover still on it so I can use that one once I get it off (have to break crank bolt loose).  Or can I just jb weld this shit?  Wish I could drive this thing without constantly having to take it apart. 

 

Beyond frustrating at this point.  

 

 

23959518628_3531144fe1.jpg

 

37780859952_4407e63154.jpg

 

37554239020_5829a87d47.jpg

 

37764268136_cde542cd01.jpg


Re-core or replace RAD?

18 September 2017 - 08:32 AM

Just wondering what the general consensus is, I have the original copper rad in my truck which seems to have sprung a leak.   

 

I can get it re-cored or I can just buy a Koyo, what say you? 

 


L16 hesitating, quits and hard to restart

05 September 2017 - 06:36 AM

Truck gave me fits today.  

 

Took my son to school and on the way back on the freeway going 55-60 it started to hesitate in 4th.  Got off the freeway and then it died a couple times on the way home.  It sat for a couple minutes in between dying, fired up and ran, then would die, wait a couple minutes then it would run again.  When it died and I would try to start it would sometimes idle and sometimes not, if I rev'd it up and it would rev ok but if I tried to drive (load) it would die.  By trail and error I made it home.  Once I got home the truck sat for 10-15 minutes then I drove it around for 10 minutes no issues whatsoever.  

 

Any idea what could cause this?  


521 Upper control arm bushings?

03 September 2017 - 07:47 AM

Anyone have a part number for these?  

 

37002504715_1db86b0cdf_z.jpg[/url]