Jump to content


Member Since 11 Nov 2016
Offline Last Active Yesterday, 03:46 PM

#1438153 My 1971 521

Posted by d.p on 28 November 2016 - 11:05 AM

Haha thanks Hainz.  It is the truck for me and all of this is new to me so I am doing my best to try and learn.  


The reason I am bringing all this up is because I took it to this old 'Datsun mechanic' and he had me all worried about this shit.  Oil cap was leaking but I think that was because it was loose.  Radiator isn't leaking as far as I can tell, just started coming out the overflow hose today.    Like I said only backfired twice and its been running well since then.  Just dog slow but I guess that is expected.  


Inline fuel filter in between the stock one and the fuel pump? Something like this?



#1438142 My 1971 521

Posted by d.p on 28 November 2016 - 09:45 AM



  1.  Fuel filter has debris in it so safe to say my tank needs to be cleaned.
  2.  Missing the bottom bolt on the alternator, anyone know what size that is? No idea if it was ever there or worked itself loose but my alt belt is loose and no way to tighten  the alt without the bottom bolt.  Stuck a ziptie through it for now.  
  3.  Radiator fluid started coming out the overflow hose, temp gauge stays right below center when driving.  Not sure if the cap or the radiator needs to be replaced?  Radiator hoses have been replaced but the radiator itself seems to be OEM.  
  4.  Missing gasket under the oil cap  (not sure what its called?) Gasket goes on the valve cover itself.  






#1437936 My 1971 521

Posted by d.p on 27 November 2016 - 02:44 PM

Wayno yes to L16, and it backfired/lost power twice on me on that drive across the bridge...died a handful of other times as well.   Never checked the lash, is that hard to do?  I have the service manuals which walk me through it but never done it before.  


For shits and giggles I replaced the fuel filter with a clear NAPA one and the fuel is clear as day.   Haven't had time to check the gas in the tank but I will soon.  There  was some debris in the old one but no idea how long it had been on there.    


If anyone cares its NAPA part: FIL 3053



#1437554 My 1971 521

Posted by d.p on 26 November 2016 - 06:35 AM

Already did this morning.  

#1437549 My 1971 521

Posted by d.p on 26 November 2016 - 05:44 AM

Wayno, if it is the starter than that would be 2 problems because the starter wouldn't cause the truck to backfire/lose power on the freeway.  


Fuel filter looks ok?? 




I got the Haynes and Clymer repair handbooks and have been reading them to learn as much as I can.  There are also two 'reputable' shops, banzai and datsunspirit, one of whcih I am going to have my truck looked over by.  Would love to meet some local enthusiasts in MD but they seem to be a rare breed here on the east coast.  






Anyone know any Datsun enthusiasts in Maryland?  

#1437463 My 1971 521

Posted by d.p on 25 November 2016 - 08:18 PM

The end of the fuel pick up has no filter, or anything on it.  Just the end of the pipe, close to the bottom of the tank.  There is a drain plug on the gas tank of a 521.  Get the tank real close to empty, have something that can catch the gas, pull the plug, and see what comes out.   If you get a lot of crud out of the tank, let the gas you pulled out settle, and put the plug back in, put that gas back in the tank, and repeat the process.


Compression should be higher on a L-16.  Should be at least 159. at 350 RPM, and less than 10% difference. 


Ill drain it tomorrow and see what comes out.  I never had to "get the truck running" as it was running when I bought it and ran fine for the most part since then.  As far as compression goes thats what I was told it was by the PO.  I plan on having the engine looked over soon by a local Datsun mechanic will make sure they do a compression test. 

#1437133 I got another one..

Posted by d.p on 23 November 2016 - 07:19 PM

But im gonna go just a little bit lower up front sto get rid of that wheel gap. Also gonna have to roll the rear quarters a tiny bit because the bed sides rub the tires if I put enough weight in the back. Once rolled it wont be a problem


What won't be a problem?  hitting the bump stups or riding like shit?  

#1437125 My 1971 521

Posted by d.p on 23 November 2016 - 06:57 PM

wayno don't fucking jinx me!  Besides I got a modern car I can drive when this fucker decides to act up.  


Soaking the fuse box right now in vinegar and little lemon juice.  Is the IGN light bad or something?  Pretty cool you can remove all the fuses until you do that and the truck refuses to turn on again. You like to live dangerously? 

#1437070 My 1971 521

Posted by d.p on 23 November 2016 - 03:44 PM

Thanks Mike.


Ran into another issue today.  Turn signals work fine when the lights are off, if I turn on the parking lights they work sometimes, but if I turn on the headlights they don't work 9/10 times.  


-Flashers work with the truck off and on and they work with the lights off and on.  

-Turn signals are only seem to be work consistently with the headlights off or with the parking lights on.    If the headlights are on they don't work and are generally slow to come on.  


Any idea why that would be?

#1436835 I got another one..

Posted by d.p on 22 November 2016 - 12:57 PM

remember youll get axle wrap when removing springs.

going that low is for looks.


do 3 inch in rear and drop the front and call it good


Ok, send me that pic of the bolt in the front that I can use to lower it.   :thumbup:

#1436785 I got another one..

Posted by d.p on 22 November 2016 - 08:08 AM

How is the ride that low?  Can you still use the bed?

#1436765 My 1971 521

Posted by d.p on 22 November 2016 - 06:51 AM

Plan on having the engine given a once over by a local Datsun mechanic.  For the most part the truck runs fine just a little hiccup here and there.    Dropped off the door card to be fixed, going to put some water resistant backing in it and replace all the clips.  


Oo another note is the choke supposed to be hard to pull?  Mine works just need to use force to pull it out.  

#1435876 My 1971 521

Posted by d.p on 18 November 2016 - 04:51 PM

Maybe your dip stick tube is cracked or loose at the bottom, I am not inclined to tell you to pull on it to see if it will come out as I am afraid you could break it, but that is what I would do, but I have the tools to extract the broken part if it did break on me, not sure about your tool collection.

Have you tried cleaning it with a spray cleaner of some type like Lectra-Motive and then using some kind of heat resistant glue/epoxy/gasket maker around the base to stop the leak? 


Nah, only thing I did was spray some carb cleaner on the block and wipe it down to see if I could pinpoint it.  Still not %100 sure and don't have the tools to extract it if it breaks so I won't mess with it until someone who knows more than me looks at it.


Vent hose goes to the stock air filter housing, so how would I check for a stuck valve?  

#1435811 My 1971 521

Posted by d.p on 18 November 2016 - 12:37 PM

Datzenmike, post a photo so I know what I am looking at.   Lubed up the passenger hinge and its all quiet now so that is good.  


Anyone have the piece circled in red?  Seems like at some point it was lost on my truck and someone made one out of a screw and washers which fell apart today.  



#1435779 My 1971 521

Posted by d.p on 18 November 2016 - 09:06 AM

Which top nut? I can adjust the ride height in the front without re indexing it?

Also Driver side door handle shit the bed today. Outside handle stopped working...Screw (screw with a bunch of washers on it)that allows the plastic arm to release fell out. I was able to save it but the nut is gone. Going to be bitch putting that screw back in with the nut on the backside. Also the door card is all dead on he backside and the metal clips holding it on pretty much detached from the card. Which sucks.