Jump to content


Crashtd420

Member Since 02 Nov 2016
Online Last Active Today, 07:00 AM
-----

#1491796 where to find a 720 parking brake cable

Posted by Crashtd420 on Yesterday, 04:51 PM

$1,000 for some wire?


Atleast it's free shipping....


#1491520 Changing front wheel bearings

Posted by Crashtd420 on 26 May 2017 - 04:27 AM

Ok I'm bored ...

The only parts that would need to be fitted and honed are the king pin bushings...
Most of the slip fit stuff like #87... and even the kingpin as it fits into #27/#28 shouldn't need it but I had to do a slight hone so they slipped in better... was probably just rust ...

And be careful with those small anti rotation pins.... #88 maybe even #18...
I think they come with the king pin kit but I didn't get ones for the lower link #88.... had to reuse....

Not sure about how the other stuff wears out or not... or how reusable things are once removed....
In my opinion the only 2 parts that should wear are the upper link bushing and the king pins bushings....
I guess it all depends on how much or little you wanna replace...


#1491516 Changing front wheel bearings

Posted by Crashtd420 on 26 May 2017 - 03:58 AM

Wayno has most of the parts covered for you....
This is the #83 you mentioned..

Screenshot_20170526-073802_zpsyn8rdops.p
That #83 part has a steel sleeve inside the rubber.. on mine the bolt and sleeves rusted together.... I had to separate everything then cut the bolt out.....

I'll let others comment on the rest...


#1491411 External Oil Filter not circulating/Oil P. Light on and off with RPM

Posted by Crashtd420 on 25 May 2017 - 01:13 PM

Left would be the driver's side.

L16/18 and L20B are only different in height just below the head (2cm) Mount location should be the same and oil filter clear. Tons of room.


Sounds like he means left as he's looking at the motor....
I mess that up too....

There is definitely something missing to this whole story.....


#1491178 External Oil Filter not circulating/Oil P. Light on and off with RPM

Posted by Crashtd420 on 24 May 2017 - 11:15 AM

I had a similar problem with my oil filter, won't get into that but what I found was...
Stock is a S8A. . 4.5 inches long
A bosch 3402 will work and is 3.75 long..
Also bosch 3321 is 3.25 inches long
Also stp s7328 is 3.25 inches.
And I won't even mention the fram....


#1491000 External Oil Filter not circulating/Oil P. Light on and off with RPM

Posted by Crashtd420 on 23 May 2017 - 05:34 PM

Probably the only reason the light is going off is the pressure release valve... there is a ball valve where the oil filter goes.... at a certain pressure it opens bypassing the filter to maintain oil flow if the filter became clogged.... the oil pressure sensor light is after the filter/valve
So personally I think your pump is fine but sounds line a block on the adaptor..
Can you remove the adaptor?
Maybe something is blocking the line or it has to be positioned a certain way...
But that's my opinion...


#1490922 Valentine

Posted by Crashtd420 on 23 May 2017 - 11:19 AM

Same here.... found mine....
It's been sand blasted clean and painted with por15 . .. I don't know where anyone lives but I am up in Massachusetts..
if hogie is closer and gets you on the road quicker by all means go with him....

20170523_151429_zps9o0wpgkp.jpg


#1490877 Valentine

Posted by Crashtd420 on 23 May 2017 - 08:22 AM

And sky I'm off work in a few hours... I head right home to work on my 521 so while the compressor is builds pressure I'll take a look.... I'll message you one way or anothet


#1490875 Valentine

Posted by Crashtd420 on 23 May 2017 - 08:20 AM

Stroffgren he still has his 2 piece driveshaft....

Hobo I think they are different... at least the rubber part of the carrier bearing are.. the 620 carrier is round while the 521 has a wierd shape.... little wings or something on the bottom.... anti rotation or something... no idea....


#1490864 Valentine

Posted by Crashtd420 on 23 May 2017 - 07:28 AM

I might have what you need....
Do you need both pieces or just that bottom?... I am using the top, almost as a catch incase something went wrong but I am not using that bottom piece.
I used a carrier bearing from a volvo on mine... had a nice bracket built in to bolt it down...
I need to locate in my garage but I am sure I have it....


#1490770 Deceleration popping at exhaust with new MSA Premium exhaust

Posted by Crashtd420 on 22 May 2017 - 08:03 PM

The match


#1490167 My 1971 521

Posted by Crashtd420 on 20 May 2017 - 02:30 PM

Datsun grill emblem?.... are we suppose to have one?
I did this on mine because I only had one fender emblem.....
20170520_182133_zpsueohirjj_edit_1495319


#1489526 Stock Hitachi gasket?

Posted by Crashtd420 on 18 May 2017 - 06:46 AM

Yup....
  • d.p likes this


#1489242 720 idle issues.

Posted by Crashtd420 on 17 May 2017 - 08:15 AM

That look exactly like the transmission in my basment.... short 71b....
Mine did have Zl71b in raised letters on the side...


#1489191 Remove dust cap Front wheel bearing

Posted by Crashtd420 on 17 May 2017 - 03:05 AM

I measures mine and a 2 1/8 id pipe is what should slip over the dome....