Jump to content


serum114

Member Since 11 Mar 2014
Offline Last Active Today, 05:03 AM
-----

#1435255 DatsunsNW future plans and events

Posted by serum114 on 16 November 2016 - 10:21 AM

Hi steve

I was going to swing by your November monthly meeting on the 19th, and just wanted to make sure all the info in previous posts, as far as dates and times, still apply?

Thanks can't wait to meet DNW!




#1374425 Weber DGV 32/36 using Factory Linkage

Posted by serum114 on 18 April 2016 - 12:42 PM

The linkage looks like this:

 

20150316_160809_resized_2.jpg?v=14268749

 

The DGV throttle arm/lever looks like this:

 

99007116-1.jpg

 

End of cable mounts to one one those holes.




#1374403 Weber DGV 32/36 using Factory Linkage

Posted by serum114 on 18 April 2016 - 11:37 AM

I've got a 32/36 installed in my 510 with an aftermarket pedal and cable set up.

The cable works fine but I would like to switch over to use the factory linkage.

 

My question is: what are people using for throttle levers?

I don't see anything that weber makes that would work so I'm guessing custom or using the lever from a stock hitachi unit?

 

Here is a screen shot from a video of a gentleman who appears to have the same setup:

 

maxresdefault.jpg

 

Part number 33 is the lever from the Hitachi Carb Below

 

510_011K_1_xga.png




#1326804 Power Problems...Not Bogging? L-16

Posted by serum114 on 09 December 2015 - 11:17 AM

I had a similar issue for a while (engine revved fine in idle but not under load). I kept messing with the fuel delivery/Carb (DGAV) but it ended up being an electrical/charging issue.

I rewired and swapped my externaly regulated alternator with a higher amp internally regulated unit and it's pulling hard now. New Plugs/Wires helped a little too.