Jump to content


Member Since 22 Dec 2011
Offline Last Active Mar 18 2018 10:44 PM

#1550147 1977 620 KingCab Deluxe

Posted by 5t341tH on 07 March 2018 - 06:43 PM

Thanks for the info. What did you do with the load sensing module under the truck? Still there or long gone?

#1550146 Airdam indecisiveness

Posted by 5t341tH on 07 March 2018 - 06:39 PM

Looks good on there. How much did you pay for each lip

#1549369 1977 620 KingCab Deluxe

Posted by 5t341tH on 02 March 2018 - 10:17 PM

I'd like to get a bigger master. What year car should I order for?

15/16 Master :cool:


Goal for the rear brakes is a functional ebrake.

More to come.

#1548320 Ball joint coilover mount help

Posted by 5t341tH on 26 February 2018 - 07:36 AM

Yes I was finally able to reach out to Jason. He did verify that I have the wrong upper set. Strange as to how the rest of my order was correct but only the uppers were sent wrong. He advised on continuing with what I have and I will have to weld additional pieces to the way I have it now for safety.

#1547427 620 SR20 Motor Mounts

Posted by 5t341tH on 21 February 2018 - 09:20 PM

Hey I’ve been talking to you on fb. Please post up mock up pictures when you get a chance. Also what engine mounts? 620 or 240sx? Also, what do you mean by alternator relocate? Stock placement won’t work?

#1547295 Airdam indecisiveness

Posted by 5t341tH on 21 February 2018 - 11:39 AM

I like the Camaro one...

#1546843 DIY Double wall tailgate for 620

Posted by 5t341tH on 18 February 2018 - 09:40 PM

That doesn't fix the issue, the fix makes it so you can see your own photos, but you still cannot see others photos, I cannot see any photos in this thread and I do have the fix/extension, he is talking about the original posters photos, and he has not been logged in for over a year.


I see all pictures. try a different plugin

#1546731 DIY Double wall tailgate for 620

Posted by 5t341tH on 18 February 2018 - 09:34 AM

google up "photobucket fix" and you will have all your pictures back. firefox and chrome both have the fix for it

Too bad all the pictures are gone...... :(

#1545597 521 SR20 Motor Mounts

Posted by 5t341tH on 12 February 2018 - 07:49 PM

So how's it going for the 620 mounts? I'm about to pick up an SR20

#1544366 Help wiring intermittent wiper switch

Posted by 5t341tH on 05 February 2018 - 09:48 PM

I'm more concerned with why my intermittent wipers don't work. Its using the harness and i wired the required blue/red wire to a constant 12v. What could it be? The delay box clicks like it should but the wipers don't wipe. and yes it's the OE switch

#1544290 Help wiring intermittent wiper switch

Posted by 5t341tH on 05 February 2018 - 05:19 PM

Hello all. I just got the intermittent wiper switch and trying to install it. I wired it to my 78 and i can’t seem to get it to work intermittently. I did follow the how-to in that section. I powered the blue/red wire with always hot 12v. I can hear the relay box click when I have the switch in that position but the wipers don’t wipe. The wipers do work in the slow and fast setting. One thing I do notice though, when I make them wipe in slow or fast, the don’t return to the down position when I turn them off before the fully cycled. Any suggestions?

#1543051 Mine now ('74 Cactus Green)

Posted by 5t341tH on 30 January 2018 - 07:57 PM

How does the speedometer read? It says GPS. Do you have the gps unit mounted somewhere?

#1540059 Datsun 620 ultimate SS exhaust

Posted by 5t341tH on 13 January 2018 - 11:33 AM

Where’d you get that sexy flange

#1535385 Trucky-chan KA-T 620 project

Posted by 5t341tH on 18 December 2017 - 09:44 PM

nice looking hood latches. how do they attach together?

#1530470 Bruiser! 78 620 KC project

Posted by 5t341tH on 20 November 2017 - 10:47 AM

Well, last night I set out to replace the steering box seal as the girls have a horse show this weekend and I don't want them stranded with a broken box.


I bought a "front end repair kit" at Harbor Freight, one of the pitman arm pullers was just the right size.




However, being a Harbor Freight tool, the amount of force I was willing to put into the tool was not enough to pop the arm loose.  I tried wedges between the tool and the steering box and also tried hitting the pitman arm with a hammer and a long screwdriver from the top of the engine compartment.  Nothing would make it budge and I didn't want to overstress anything inside the box by going caveman on the thing.  So I cleaned up the everything as good as I could with a rag and got out the propane torch.  After a few minutes of heat application to the pitman arm around the steering box shaft, I re-hung the puller, cranked the bolt, and the arm came right off.




The seal took a while too, but eventually I persuaded it to come out with a flat screwdriver and some careful prying motions.




New seal in place and seated with a deep socket.




I reconnected the arm, torqued the giant nut, filled the box with 90W, cleaned up, and went to bed.


This morning there was not a drip in sight.  VICTORY!!!

nice work. Where can I get that seal? Mine is leaking too and I didn't know there was a seal under there