Jump to content


Son_of_a_Datsun_Guy

Member Since 13 Dec 2011
Offline Last Active Today, 11:01 PM
-----

Profile Feed

Photo

Son_of_a_Datsun_Guy

Do we have a thread for magazine/e-zine articles about Datsuns? I'd love to stay in the loop whenever a group like Speedhunters or Grassroots Motorsports does a feature on a Datsun. I have a couple bookmarked that I think deserve to be posted...
Jan 31 2016 03:05 PM
  • Loren O's Photo
    Loren O
    I would definitely follow a thread like that,if there is one
    Feb 01 2016 07:32 AM
  • Lockleaf's Photo
    Lockleaf
    Seems like sightings would be a good place to put those
    Feb 02 2016 10:11 AM
  • Eagle_Adam's Photo
    Eagle_Adam
    Start one ;)
    Feb 03 2016 12:07 PM
Photo

Son_of_a_Datsun_Guy

RaaaaaaaAAAAAP! Bahrooooomzzzzz *snap* *crackle* *pop*.
May 02 2014 09:11 PM
  • Son_of_a_Datsun_Guy's Photo
    Son_of_a_Datsun_Guy
    Man I love 10:1 compression, SUs need a tune though... I monkeyed with them too much trying to adjust the richness and now I need to just start from scratch again.
    May 02 2014 09:12 PM
Photo

Son_of_a_Datsun_Guy

RaaaaaaaAAAAAP! Bahrooooomzzzzz *snap* *crackle* *pop*.
May 02 2014 09:11 PM
Photo

Son_of_a_Datsun_Guy

So I've been without the wagon here at college for about two months now... about ready to get her back. She's having some exhaust work done and a bit of body, both being done by Luke, my dad and I's good friend and master fabricator. She'll be down in about two weeks. Can't wait.
Oct 30 2013 10:52 PM
Photo

Son_of_a_Datsun_Guy

Finally got my EI dizzy to work. Turns out the wires to the coil were bad somehow. Three days of troubleshooting to find out a butt connector was bad.
Sep 07 2013 02:19 AM
  • DAT510's Photo
    DAT510
    Electrical sucks
    Unlike other things where you can beat the shit out it, electrical work beats the shit out of you, mentally lol
    Sep 07 2013 08:36 AM
  • flatcat19's Photo
    flatcat19
    Source, load, ground. It's that easy. Go to Toys 'R Us and pick up My First DVOM and have a ball.
    Sep 07 2013 08:25 PM
  • Son_of_a_Datsun_Guy's Photo
    Son_of_a_Datsun_Guy
    That's the odd thing, when I checked the voltage getting from the battery to the coil it was good, coil to the distributor was good too. Something about the butt connector was causing an intermittent load or something like that. Couldn't tell on the meter, but it wouldn't produce a spark.

    Sep 08 2013 12:37 AM