Jump to content


Photo
* * * * * 2 votes

What did you do to your truck today?


  • Please log in to reply
2040 replies to this topic

#2021 mainer311

mainer311

    Senior Member

  • Senior Member
  • PipPipPipPip
  • 541 posts
  • Location:Massachusetts
  • Cars:1968 SPL311 Roadster, 1971 PL521 Pickup

Posted 10 November 2017 - 04:46 PM

Got the suckers and the blowers cleaned and back on.

AqjPJK9.jpg

#2022 thisismatt

thisismatt

    Senior Damon

  • Senior Member
  • PipPipPipPipPip
  • 7,954 posts
  • Location:Santa Barbara, CA
  • Cars:'71 521, '69 521 donor

Posted 10 November 2017 - 05:45 PM

Why aren't you using studs for the manifolds?


I'm your huckleberry.

One jump ahead of the lawmen
That's all, and that's no joke
These guys don't appreciate I'm broke

#2023 mainer311

mainer311

    Senior Member

  • Senior Member
  • PipPipPipPip
  • 541 posts
  • Location:Massachusetts
  • Cars:1968 SPL311 Roadster, 1971 PL521 Pickup

Posted 11 November 2017 - 05:37 AM

Why aren't you using studs for the manifolds?

Because it didn’t come that way.

There are still 3, both ends and center. The bolts I took out are the old dished head style, so I can only assume either it came that way, or the bolts were replaced a very long time ago.

#2024 gene knight

gene knight

    Hall Monitor

  • Senior Member
  • PipPipPipPip
  • 1,749 posts
  • Location:laveen/phoenix, az.
  • Cars:various datsun toys, vw bug, chevy silverado, mitsubishi outlander,plymouth barracuda fastback

Posted 21 November 2017 - 03:59 PM

worked on sweet pea 521, removed the 620 steering gearbox and column and put the og setup back in after fiddling with the end that goes into box worm gear



#2025 Genaro

Genaro

    Newbie

  • Members
  • Pip
  • 25 posts
  • Location:Neuquen, Patagonia Argentina
  • Cars:1980 Datsun 720 Deluxe Cab 4x2 - 2001 Suzuki Jimny JLX

Posted 25 February 2018 - 07:16 AM

Hi guys/girls!
I was having issues with the temp indicator, checked the gauge, the cable, the connector, fuse box...but the only problem was bad contact to ground, so if happens to you check it first. Sender its original 1980, and works great...
WP_20180222_001.jpg

Window handle got broken by a friend, and i was lucky enough to get the last original one in the Nissan store i buy from...
WP_20180220_002.jpg

Yesterday i installed new shock absorbers, it drives much better now... Strange how one doesnt perceive how tired shocks are until installing new ones...
WP_20180224_011.jpg
WP_20180224_013.jpg

Cheers..!

#2026 Charlie69

Charlie69

    Senior Member

  • Senior Member
  • PipPipPipPipPip
  • 6,822 posts
  • Location:Tolleson, AZ
  • Cars:1966 520, 1967 520, 1985 720 ST King Cab, 1986 720 King Cab

Posted 27 February 2018 - 05:27 AM

Keep it working Genaro!



#2027 millican

millican

    Advanced Member

  • Members
  • PipPipPip
  • 164 posts
  • Location:Ocean Springs, MS
  • Cars:1982 Datsun 720, 2004 Honda Helix

Posted 12 May 2018 - 11:21 AM

We took an SPL meter with us shopping for a new bed for the guest room today. On the interstate, it's pretty consistent: 95 to 100 db. No radio. (Can't hear it anyway)



#2028 hustlepower

hustlepower

    Newbie

  • New Members
  • Pip
  • 4 posts
  • Location:SF Bay Area
  • Cars:521

Posted 13 May 2018 - 09:33 PM

I replaced my fuel pump, but it turns out that's not the problem.

My truck wouldn't start and I looked and no gas in the carb thru the sightglass. I pulled the line off the fuel pump and no fuel coming out when I cranked it.

I took the pump apart and nothing's torn, I can't tell if the check valves work ok though.

I had a new pump, it looks like carnival prize quality but whatever. Stuck it in and still no fuel coming out of it.

I think something wrong with line from tank to pump. Otherwise could be with cam actuation, but that seems less likely.

#2029 KoHeartsGPA

KoHeartsGPA

    Datsunahaulic

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 10,231 posts
  • Location:Eugene, Or
  • Cars:1970 2-door 510, 1977 620 KC, 1973 610 Goon.

Posted 16 May 2018 - 01:17 PM

Last Monday, I swapped out the new failed alternator for a "new" one (reman unfortunately) on my KA24e swap 620 since nobody seems to carry new parts anymore

#2030 Charlie69

Charlie69

    Senior Member

  • Senior Member
  • PipPipPipPipPip
  • 6,822 posts
  • Location:Tolleson, AZ
  • Cars:1966 520, 1967 520, 1985 720 ST King Cab, 1986 720 King Cab

Posted 16 May 2018 - 09:08 PM

I drove the shit out of my 86 king cab piece of shit according to Mr Tanker LOL



#2031 captain720

captain720

    Senior Member

  • Senior Member
  • PipPipPipPip
  • 658 posts
  • Location:Washington (the dry side)
  • Cars:1986 and 0 Nissan 720 King Cab 4wd and 2wd, 1991 Chevy S10 2wd

Posted 19 May 2018 - 07:38 PM

I hauled like 1600 lbs of retaining wall blocks (conservative estimate) in my 720, I'm always amazed with what that truck can do, punches so far above it's weight.

1986 and 0 Nissan 720 kc with a 1984 Z24 (third engines the charm?) http://community.rat...y-first-pickup/
1986 and 0 Nissan 720 kc 2wd http://community.ratsun.net/topic/71766-one-wasnt-enough/

My channel https://www.youtube....KfpiwEzpECyevzw

 

Datsun=Project


#2032 Rick-rat

Rick-rat

    Senior Member

  • Senior Member
  • PipPipPipPip
  • 1,044 posts
  • Location:Wa
  • Cars:1979 620 K C

Posted 25 May 2018 - 04:16 PM

Scared my truck into fixing itself, was told front turn signals were not working, when the truck saw me coming with toolbox and power tools, the signals started working fine :thumbup:



#2033 KoHeartsGPA

KoHeartsGPA

    Datsunahaulic

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 10,231 posts
  • Location:Eugene, Or
  • Cars:1970 2-door 510, 1977 620 KC, 1973 610 Goon.

Posted 27 May 2018 - 11:34 PM

Last Monday, I swapped out the new failed alternator for a "new" one (reman unfortunately) on my KA24e swap 620 since nobody seems to carry new parts anymore


Today I swapped out that ^ alternator....what the flying fuck!!!!!

I spent hours going through my entire harness looking for the cause of the alternator not charging, found nothing, pulled it, took it to auto parts store to get it tested.....failed....got another "new one" will see how long this one lasts....this is really upsetting.

#2034 Mesk1

Mesk1

    Newbie

  • Members
  • Pip
  • 26 posts
  • Location:Tucson, Arizona
  • Cars:78 620

Posted 28 May 2018 - 03:28 PM

Took out the 4 speed tranny and drive shaft, getting ready for truck Ka24e swap. I’m sun burnt like a mofo. Hellboy if you will.

#2035 Charlie69

Charlie69

    Senior Member

  • Senior Member
  • PipPipPipPipPip
  • 6,822 posts
  • Location:Tolleson, AZ
  • Cars:1966 520, 1967 520, 1985 720 ST King Cab, 1986 720 King Cab

Posted 28 May 2018 - 07:13 PM

You live in Tucson and work on your truck naked. all I can say is Dumb ass!  LOL



#2036 Mesk1

Mesk1

    Newbie

  • Members
  • Pip
  • 26 posts
  • Location:Tucson, Arizona
  • Cars:78 620

Posted 28 May 2018 - 07:34 PM

You live in Tucson and work on your truck naked. all I can say is Dumb ass!  LOL

i always seem to ferget that dam sun block  :w00t:



#2037 KoHeartsGPA

KoHeartsGPA

    Datsunahaulic

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 10,231 posts
  • Location:Eugene, Or
  • Cars:1970 2-door 510, 1977 620 KC, 1973 610 Goon.

Posted 29 May 2018 - 03:55 PM

Rock lobster!



#2038 Charlie69

Charlie69

    Senior Member

  • Senior Member
  • PipPipPipPipPip
  • 6,822 posts
  • Location:Tolleson, AZ
  • Cars:1966 520, 1967 520, 1985 720 ST King Cab, 1986 720 King Cab

Posted 31 May 2018 - 05:25 AM

Clothes would help!  lol



#2039 Farmer

Farmer

    Senior Member

  • Senior Member
  • PipPipPipPipPip
  • 2,535 posts
  • Location:Grants Pass, Or
  • Cars:'78 Datsun 620 KingCab

Posted 31 May 2018 - 12:54 PM

Got the exhaust hooked up. But now have to drop gas tank and clean fuel system.

#2040 Mesk1

Mesk1

    Newbie

  • Members
  • Pip
  • 26 posts
  • Location:Tucson, Arizona
  • Cars:78 620

Posted 01 June 2018 - 04:49 AM

Clothes would help!  lol


It's just the natural color lighter folk get in az, the rock lobsters