Jump to content


Photo
- - - - -

Need help 1976 datsun 620


  • Please log in to reply
9 replies to this topic

#1 yifith

yifith

    Newbie

  • New Members
  • Pip
  • 3 posts
  • Location:Spanaway,wa
  • Cars:Datsun 620

Posted 29 April 2018 - 11:44 AM

Ok so I changed my valve cover gasket today and didn’t touch anything els.when I was done hooked up the spark plug plugs and when to start it,it won’t start.it cranks but don’t start.the carburetor spits out a little gas and smoke coming out...any advice I’m so lost.thank you.

#2 yifith

yifith

    Newbie

  • New Members
  • Pip
  • 3 posts
  • Location:Spanaway,wa
  • Cars:Datsun 620

Posted 29 April 2018 - 11:53 AM

Need help I changed my valve cover gasket put the spark plugs back together and and try to start it it won’t start.it cranks and the Weber 32/36 carburetor spits out a little gas and little bit of smoke and it won’t turn on.before I did I all this truck was running perfect.

#3 Doctor510

Doctor510

    Senior Member

  • Senior Member
  • PipPipPipPip
  • 730 posts
  • Location:Mesa, AZ
  • Cars:Many 510's

Posted 29 April 2018 - 01:27 PM

Check the firing order.  COUNTER CLOCK WISE 1-3-4-2



#4 flatcat19

flatcat19

    Back in Black

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 20,710 posts
  • Location:Tri-Cities, WA/PDX
  • Cars:Smaller. Better. Slower. Lower.

Posted 29 April 2018 - 01:32 PM

Wires on wrong plugs.

Roll to TDC. Rotor from distributor now points at the #1 position. Plug wire going to spark plugs number one.

Now install the rest of the wires in order.

1-3-4-2 in a counter clockwise order.

It's possible if wire order is correct, maybe wire not fully seated against plug.

You can't hang if your nuts haven't dropped...it's physics


#5 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 72,276 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 29 April 2018 - 02:07 PM

2 and 3 are swapped.
 
 
Forrest-Gump-GQ-19May16_b.jpg

It Haaapens
Posted Image

#6 yifith

yifith

    Newbie

  • New Members
  • Pip
  • 3 posts
  • Location:Spanaway,wa
  • Cars:Datsun 620

Posted 29 April 2018 - 04:00 PM

So I put the spark plug wires back.now when I cranks it exhaust back fire...did Is the the valve cover?ive put gasket and Rtp...

#7 racerx

racerx

    Senior Member

  • Senior Member
  • PipPipPipPipPip
  • 5,188 posts
  • Location:NorCal
  • Cars:71 Datsun 510 and 65 Mustang Fastback

Posted 29 April 2018 - 04:40 PM

Maybe the coil wire?

#8 flatcat19

flatcat19

    Back in Black

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 20,710 posts
  • Location:Tri-Cities, WA/PDX
  • Cars:Smaller. Better. Slower. Lower.

Posted 29 April 2018 - 04:41 PM

Timing is off.

Did you turn or bump the distributor at all?

You can't hang if your nuts haven't dropped...it's physics


#9 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 72,276 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 29 April 2018 - 07:10 PM

Plugs are wet. Try in the morning.


Posted Image

#10 banzai510(hainz)

banzai510(hainz)

    L motor God

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 15,360 posts

Posted 30 April 2018 - 06:11 AM

when changing a valve cover gasket one only needs to unclip the distributor cap and fold over the wires and clip dist cap back on. Simple

 

 

did you pull the plug wires and the ends inside bust off? that could be a issue


Throw on some Weber sidedrafts, Rising Sun hood.... call it good