Jump to content


Photo
- - - - -

turn signals dont work, but the emergency flasher works


  • Please log in to reply
5 replies to this topic

#1 ecg510

ecg510

    Newbie

  • New Members
  • Pip
  • 2 posts
  • Location:oceanside
  • Cars:1971 510, 510 wagon, 210 wagon

Posted 28 December 2017 - 09:52 PM

so i replaced the flashers and fuses, and only my emergency flasher works, any one have a suggestion? i also replaced the bulbs.



#2 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 70,286 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 28 December 2017 - 10:09 PM

The turn signal flasher goes through the 4 way flasher switch. It is disconnected during 4 way use so the turn flasher does not interfere and is re-connected when the 4 way switch is turned off.

 

Turn the signal on and move the 4 way switch on an off multiple times to clean the contacts. Then try moving the switch just slightly towards the ON position and see if the turn begins flashing.

 

If your red oil pressure and ignition lights up when the key is on then the fuse is ok.


Posted Image

#3 banzai510(hainz)

banzai510(hainz)

    L motor God

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 15,058 posts

Posted 29 December 2017 - 10:16 AM

reseat connections ????


Throw on some Weber sidedrafts, Rising Sun hood.... call it good

#4 ecg510

ecg510

    Newbie

  • New Members
  • Pip
  • 2 posts
  • Location:oceanside
  • Cars:1971 510, 510 wagon, 210 wagon

Posted 29 December 2017 - 10:07 PM

thanks ill try that, ill reply soon B)



#5 hang_510

hang_510

    too ol'skool

  • Senior Member
  • PipPipPipPipPip
  • 9,652 posts
  • Location:so.cal
  • Cars:71 2 door - LZ22 / 72 wagon - TBD

Posted 30 December 2017 - 09:48 AM

My indicator switch is intermittent, have to slam it R sometimes to work.
Those contacts gets worn and dirty as well.

"I can spend time working on the Dattos, or wasting money at the strip club. You make the call." :D


I'll put on chain mail and a dirt bike tire jock strap and drive it!!!!!


#6 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 70,286 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 30 December 2017 - 10:03 AM

Get a test lamp and look for 12v on the turn signal flasher. Check both sides.

If no power then it is stopped by the 4 way switch. Maybe the 4 way harness plug in the steering column?

If 12v present on only one side... the flasher is bad

If 12v present on both then there is something wrong towards the turn signal switch. Maybe the turn signal harness plug in the steering column?

 

 

Last thing would be taking the steering wheel off and inspecting the switch. Seems unlikely both and not one side would stop working. Look for something loose or broken and hose down with electrical contact cleaner and try.


Posted Image