Jump to content


Photo

Battery drain? Help!!


  • Please log in to reply
26 replies to this topic

#21 tr8er

tr8er

    Datsun Mechanic

  • Senior Member
  • PipPipPipPipPip
  • 7,310 posts
  • Location:Hawaii
  • Cars:'71 PL510; 01 Frontier 4X4

Posted 01 January 2018 - 01:13 PM

That lamp has to be in the circuit or the alternator won't energize. Sometimes if you rev it up there is enough residual magnetism to get it going. Then it will charge till you shut it off. But generally the reason the red light comes on with the ignition is to tell the driver that the bulb is good. If the bulb is good that alternator gets a mild 12v signal to energize the field coils. Better get that dash light fixed.


This sounds promising.

#22 Acardiel11

Acardiel11

    Member

  • Members
  • PipPip
  • 53 posts
  • Location:Lancaster
  • Cars:1974 Datsun 620

Posted 01 January 2018 - 02:35 PM

Interesting. I will definitely get that fixed then. Does anyone happen to know which color wire goes to the red light on the dash?

#23 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 71,821 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 01 January 2018 - 02:38 PM


Yes it got dimmer and dimmer. Not sure on the red lamp light. I pulled the dash off a long time ago and didn’t label wires so I don’t believe that light is hooked up. It was working before I pulled the dash though. Let’s say the red lamp light was lite up. What does that tell you?

 

How the hell do you operate without your gauges warning lights and a dash??????????????

 

 

White/Red stripe goes back to the alternator, it's the #6 position on the round plug but the other side of the lamp goes to the Yellow/Red wire that finds it's way to the fuse box and is turned on by the ignition switch..


Posted Image

#24 banzai510(hainz)

banzai510(hainz)

    L motor God

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 15,260 posts

Posted 02 January 2018 - 06:23 AM

WTF????????????

 

I said it, the alt wasnt charging running off the battery


Throw on some Weber sidedrafts, Rising Sun hood.... call it good

#25 Acardiel11

Acardiel11

    Member

  • Members
  • PipPip
  • 53 posts
  • Location:Lancaster
  • Cars:1974 Datsun 620

Posted 02 January 2018 - 05:44 PM

haha all the gauges work but the battery warning light. Haven’t been able to get around the some testing with the holidays. Hopefully I can get to it sometime this week

#26 Acardiel11

Acardiel11

    Member

  • Members
  • PipPip
  • 53 posts
  • Location:Lancaster
  • Cars:1974 Datsun 620

Posted 02 January 2018 - 05:55 PM

Yeah I think I’m going to pull the alternator again and get it tested somewhere else.

#27 Figbuck

Figbuck

    Senior Member

  • Senior Member
  • PipPipPipPip
  • 737 posts
  • Location:Portland, Oregon
  • Cars:'73 620 that I bought new.

Posted 03 January 2018 - 06:24 PM

I had the same symptoms where there was a slow drain on the battery. New Battery, started and ran fine until the truck sat for a couple days and the battery was drained dead.

It drove me nuts until Mike, Hainz got me to trouble shoot all the basics... long story short... the two wires to the alternator got swapped when I chucked my stock L16 35amp externally regulated alternator, with a 60amp internally regulated unit from a 720. A clue if I remember right... no alternator light lit when the ignition was turned on. After the alternator light on the dash works right. Truck can sit for weeks now even though the clock on my CD player draws current.

"What ever you do, don't add up what you are spending! :D
J2eDeYe

 

FigbuckAvitar2_zpsb3d7c6da.jpg