Jump to content


Photo
- - - - -

Oil pressure on Z20 engine?


  • Please log in to reply
26 replies to this topic

#21 thisismatt

thisismatt

    Senior Damon

  • Senior Member
  • PipPipPipPipPip
  • 7,884 posts
  • Location:Santa Barbara, CA
  • Cars:'71 521, '69 521 donor

Posted 30 December 2017 - 12:56 PM

I would imagine the turbo oil feed drops the stock pressure a bit
I'm your huckleberry.

One jump ahead of the lawmen
That's all, and that's no joke
These guys don't appreciate I'm broke

#22 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 72,225 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 30 December 2017 - 01:49 PM

Normally a restriction in line is used. It does not need a 1/8" line to lube it.
 
Just look at the oil jet in the top of the block that sends oil to lube all the cam bearings, timing chain and all the rocker arms. It's just a pin hole.
 
SW5E026.jpg

This is my Z22 block I decked 1mm.
Posted Image

#23 Spiff

Spiff

    Advanced Member

  • Members
  • PipPipPip
  • 233 posts
  • Location:Norge
  • Cars:720, mazda b2200, merc s320

Posted 30 December 2017 - 04:39 PM

I'm running 10w-40 mineral, and since it has used some oil I have topped up with semi synthetic 10w-40. Nissan oem oil filter.
It's old though so might be time for an oil change regardless.
The turbo I'm running uses a restrictor in the oil feed line.

#24 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 72,225 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 30 December 2017 - 04:45 PM

Ah.... Norge. I was going to say never run 10w anything. The reason I and others run the 15w40 is because it's a diesel oil with the higher ZDDP levels we can't get in the regular oils sold here.


Posted Image

#25 Spiff

Spiff

    Advanced Member

  • Members
  • PipPipPip
  • 233 posts
  • Location:Norge
  • Cars:720, mazda b2200, merc s320

Posted 01 January 2018 - 02:37 PM

I decided to check the oilpump on the spare Z24 i have that was rebuilt several years ago. This is a KA pump isn't it?

 

image.jpg



#26 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 72,225 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 01 January 2018 - 03:02 PM

Looks like it.


Posted Image

#27 Spiff

Spiff

    Advanced Member

  • Members
  • PipPipPip
  • 233 posts
  • Location:Norge
  • Cars:720, mazda b2200, merc s320

Posted 01 January 2018 - 03:35 PM

Lucky me. Guess I'll put it on when I change my oil then