Jump to content


Photo

Engine trouble eh


  • Please log in to reply
43 replies to this topic

#41 0r0B210

0r0B210

    Advanced Member

  • Members
  • PipPipPip
  • 153 posts
  • Location:SD
  • Cars:'76 B210 & '13 Versa sedan

Posted 09 December 2017 - 01:22 AM

Could be irrelevant but, check the pickup coil/magnet's dwell gap. I only mention this because I didn't notice it mentioned, earlier, in the thread.


- 0r0_B210


#42 Dirtyowlnumber4

Dirtyowlnumber4

    Newbie

  • Members
  • Pip
  • 34 posts
  • Location:Silver City NM
  • Cars:Chevrolet S10, Cadillac DeVille, Datsun B210

Posted 11 December 2017 - 12:31 PM

Could the valves be broken and the cylinder still retain compression?

 

I was thinking of taking the head off to look at the valves, but the compression is good. I figures if the valves were broken enough to stop the engine from working, they would not hold compression at all.



#43 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 70,302 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 12 December 2017 - 07:06 PM

I can't see how they could be broken and still work. The valves are shaped like the lid on a jack 'o lantern. Tapered so they seal the combustion pressures in.


Posted Image

#44 Dirtyowlnumber4

Dirtyowlnumber4

    Newbie

  • Members
  • Pip
  • 34 posts
  • Location:Silver City NM
  • Cars:Chevrolet S10, Cadillac DeVille, Datsun B210

Posted 12 December 2017 - 07:30 PM

Cool I was thinking of taking the head off but its kind of a bitch to drain the radiator the way I've got it on I'll just wait and see what the shop says.