Jump to content


Photo
- - - - -

Rewired Headlights with relay issues!!


  • Please log in to reply
13 replies to this topic

#1 murdrdatsoon72

murdrdatsoon72

    Newbie

  • New Members
  • Pip
  • 11 posts
  • Location:Honolulu, Hawaii
  • Cars:72 datsun 510 wagon Ka24de swap

Posted 20 April 2017 - 07:35 PM

I did the rewiring of my headilghts with relays as stated in the DQ 3.1 article. I have a 72 510 wagon that the original wire harness was given to me in a box. I downloaded a complete wire diagram but appears some of the wire colors don't match. 

After many nites of of trying to figure out where things hooked up I finally fiqured it out! Everything works except the headlights. So, I decided to to the upgrade and start from scratch.

Here's the problem,

 

1) Headlight switch pushed in (off):

    With a test probe between Bat+ to High beam relay 86, high beams lights come on.

    With a test probe between Bat+ to low beam relay 86, low beam lights come on.

 

2) Headlight switch pulled all the way out and high/low beam control inwards to driver:

     With a test probe between Bat+ to low beam relay 86, low beam lights come on.

     With a test probe between Bat+ to High beam relay 86, no lights.

 

3)Headlight switch pulled all the way out and high/low beam control outwards away from driver:

     With a test probe between Bat+ to low beam relay 86, no lights.

     With a test probe between Bat+ to High beam relay 86, high beam lights come on.

 

The old headlight relay clicks when pulling out the headlight switch.

 

My confusion with the DQ article was that there was a descrepancy with the article and the diagram.

The confusion was wiring the High beam relay "86" to the red wire with white stripe.

The diagram displayed the "RB" wire to that relay.

 

Right now I'm running the red wire with white stripe to High beam relay 86. The red with black stripe wire to the low beam relay 86.

 

I tried switchin wires with the remaining red with blue stripe and solid red wire but it didnt work.

 

Please help!!

     

    

 

 



#2 murdrdatsoon72

murdrdatsoon72

    Newbie

  • New Members
  • Pip
  • 11 posts
  • Location:Honolulu, Hawaii
  • Cars:72 datsun 510 wagon Ka24de swap

Posted 21 April 2017 - 10:42 AM

Sorry for the confusion!! At the fuse box I have a red/yellow stripe wire with a male bullet connector. where does this hookup? The fuse box is not original. There are also a blue wire with a female connector not hooked up. Could this be my problem?

https://1drv.ms/i/s!...milzTSR1sIx2HJW



#3 banzai510(hainz)

banzai510(hainz)

    L motor God

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 14,788 posts

Posted 21 April 2017 - 10:49 AM

the blue wire is for aircond if I remember right if it was installed.

 

 

most people just install a H4 harness and use the old stock wiring (out passenger side headlamp connector to trigger the new harness)  15min install

 

 

the difference between the fuse boxes is the buss bar underneath.

 

take that red yell and make a jumber and short it to the battery and se if lights come on.  I had this happen also I think when the lights didn't come on and had a different fuse box. But cant remember now. could have been running lights ????????????

 

If blows up  don't blame me


Throw on some Weber sidedrafts, Rising Sun hood.... call it good

#4 murdrdatsoon72

murdrdatsoon72

    Newbie

  • New Members
  • Pip
  • 11 posts
  • Location:Honolulu, Hawaii
  • Cars:72 datsun 510 wagon Ka24de swap

Posted 23 April 2017 - 08:26 PM

Thanks for the advise. I will try that.

#5 murdrdatsoon72

murdrdatsoon72

    Newbie

  • New Members
  • Pip
  • 11 posts
  • Location:Honolulu, Hawaii
  • Cars:72 datsun 510 wagon Ka24de swap

Posted 25 April 2017 - 06:32 PM

Jumped the R/Y wire from fuse box to bat + and hi lights came on. Pulled out light switch, did not effect lights. I checked the old headlight relay and when I pull out the light switch the only power out Im getting there is a G/BL wire. I think thats for the parking lights. When I apply direct power from the bat + to 86 on relays that particular light comes on.

Can someone explain to me again how the headlight circuit works on my wagon.



#6 murdrdatsoon72

murdrdatsoon72

    Newbie

  • New Members
  • Pip
  • 11 posts
  • Location:Honolulu, Hawaii
  • Cars:72 datsun 510 wagon Ka24de swap

Posted 25 April 2017 - 07:33 PM

Apparently there is alot on this subject, I just need to do my homework and search this forum!



#7 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 67,534 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 25 April 2017 - 07:35 PM

When you turn the lights on, power is supplied to ALL the lamps. To select either HI or LOW beams you connect them to ground to complete the circuit. The headlamp relay is simply a switch to ground governed by the switch on the turn signal stalk.

 

As there are only ON and OFF possible, there can only be HI or LOW at any one time.

 

The OFF position of the relay is HI beams even if the headlamps are not on.

The ON position energizes the relay switching from HI to LOW beams.

 

This is the stock way it works.

 

 

 

On the original low beam socket....

 

Red wire is power when the headlamp switch is full out.

 

Red/Black goes to ground when on LOW beams

 

Red/White goes to ground on HI beam position.

 

 

 

I can't see how this DQ article works what ever. The Red/Black and Red/White are used to ground the relay to turn them on. Or should....

 

Would help is the relay coil was shown to see where the wires go inside.


Posted Image

#8 bananahamuck

bananahamuck

    S&S chicken/rice

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 13,139 posts
  • Location:Tumwater WA
  • Cars:It's a fucking anti-aircraft gun, Vincent.

Posted 25 April 2017 - 09:13 PM

I used the info off the realm on this subject when i did my brothers and mine. and it did seem like two of the wires were in wrong spots ( it's been quite awhile now so memory is faded) but simply switching them worked for me ..


http://www.the510rea...opic.php?t=8226



link to the diagram that was posted in that thread if you wanna copy it onto a piece of paper and such

http://www.the510rea...04ce8&mode=view

 

 

 

 

 

.


So somehow while i was driving back from Eaglerock swap meet i somehow caused YOU to post this,,,, do really think members on this site are that stupid to believe i caused it??

http://community.rat...un-for-a-while/

Yeah i guess you do,,

 

BTW ,,,, the first person to call you a pussy,,,, ya might wanna check out his ethnicity ,, cuz i don't think it's what you think it is there snowflakeboy

 


..........................I shall call it, narclops.

 

 

 


#9 murdrdatsoon72

murdrdatsoon72

    Newbie

  • New Members
  • Pip
  • 11 posts
  • Location:Honolulu, Hawaii
  • Cars:72 datsun 510 wagon Ka24de swap

Posted 25 April 2017 - 11:26 PM

Thanks guys for the advise and info. This forum is awesome!! I will try it again tomorrow :thumbup:



#10 murdrdatsoon72

murdrdatsoon72

    Newbie

  • New Members
  • Pip
  • 11 posts
  • Location:Honolulu, Hawaii
  • Cars:72 datsun 510 wagon Ka24de swap

Posted 26 April 2017 - 12:26 AM

Bananahamuck..in that wiring diagram, what is the box below the light switch. Is that the other headlight relay that is controlled by the hi and low beam stalk on the steering column?



#11 banzai510(hainz)

banzai510(hainz)

    L motor God

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 14,788 posts

Posted 26 April 2017 - 05:22 AM

Datsun 510 the stock wiring is hooked up to+ side of the battery via the fuse box. then when you put the switch to ON to put a ground on one side of the lamp connection .

this is called a switchable ground set up.  High beam is just a double ground  one for the outer and one for the inner lamps.

 

 

parking lights is switchable power on 510s.

 

now if one wires up using someone else set up(light kit of wire diagram of internet if might be now a switchable power set up.

 

 

I cant remember if this car you said you swapped a fuse box or a different harness in there. as this affects the Lights of the wrong fuse box is install if different.

 

 

when one adds a blk box relay they are grounded so it will be switchable power to activale the coil part


Throw on some Weber sidedrafts, Rising Sun hood.... call it good

#12 shacks510

shacks510

    Senior Member

  • Senior Member
  • PipPipPipPip
  • 1,438 posts
  • Location:SoCal
  • Cars:'72 510 two-door

Posted 27 April 2017 - 01:45 PM

I made a new light harness for my 510 using a separate fuse and relay for low/high, powered off the battery. The red/yellow wire coming from the headlight switch is the signal for the relays, and the high beam switch grounds the high relay to turn them on. The two headlight circuits in the fuse box are now unused with the wire tucked into the box. The lights are bright for being sealed beams, and there is no more flickering from the switch being overloaded.
"FHRITP" - datzenmike

#13 murdrdatsoon72

murdrdatsoon72

    Newbie

  • New Members
  • Pip
  • 11 posts
  • Location:Honolulu, Hawaii
  • Cars:72 datsun 510 wagon Ka24de swap

Posted 28 April 2017 - 06:43 PM

Thanks Shacks510..I will try that as my last resort! Just got down removing the double relay setup by DQ. I switched over to the single relay removing the original headlight relay as diagramed in Bananahamuck's response to my problem. Now, when I pull out the headlight switch I hear the relay working but still no lights. Same results as the double relay with original headlight relay in place.

 

Just wondering..I have a R/L wire with female connector just hanging by the headlight switch not attached to anything and its has constant 12 volts. I also have another B/R with male spade unhooked also. I have no W/R wire at the headlight switch (as noted in the single relay diagram) only a R/Y with no power but the G/L wire has constant power.

 

(I had a full head of hair when I started this two weeks ago!) :confused:



#14 murdrdatsoon72

murdrdatsoon72

    Newbie

  • New Members
  • Pip
  • 11 posts
  • Location:Honolulu, Hawaii
  • Cars:72 datsun 510 wagon Ka24de swap

Posted 28 April 2017 - 08:50 PM

IT WORKS!!!  :thumbup:

I meet a older guy who drove around the valley in a 69 510. He let me borrow his Clymer Repair manual for 510/wagons/Pickups 1968 - 1972.

The wire diagram in the book was exactly like mine. So the wire to post 2 on the light switch is black. The diagram showed a W/R wire from post 2 to Bat +. I just cut the black wire that was spliced into another black wire that was going to ground and tapped into the R/L wire (constant power) that was hanging nearby and the headlights came on!! 

I tested the hi/low beams, and they both worked great!! I also tested the rest of the lights with headlights on. No problems!!

The wire diagram I bought online also showed a W/R wire at the light switch, which I didnot have. 

Thanks again for everyones input!!