Jump to content


Photo
- - - - -

520 hesitates / fuel issue?


  • Please log in to reply
52 replies to this topic

#41 zed1

zed1

    Hall Monitor

  • Senior Member
  • PipPipPipPip
  • 543 posts
  • Location:Plano, TX
  • Cars:1966 PL520, 1969 Patrol L60, and 1970 240Z

Posted 14 December 2016 - 07:21 PM

Royze was the source of the kit, and the rebuild service.

1969 Patrol L60
1965 Patrol L60 (parts provider)
1966 PL520
1970 240Z
1990 300ZX (sold 10/13)


#42 Droski

Droski

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:San Diego
  • Cars:1966 Datsun 520

Posted 14 December 2016 - 07:24 PM

Oh okay so there's a trick to keep it from dieseling. I learned a lot today thanks !

#43 Droski

Droski

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:San Diego
  • Cars:1966 Datsun 520

Posted 14 December 2016 - 07:33 PM

Thanks for pointing me in the right directions Keith. Do you mind me asking how much they charged you for the rebuild? I will get in contact with them and purchase the kit if they have it

#44 zed1

zed1

    Hall Monitor

  • Senior Member
  • PipPipPipPip
  • 543 posts
  • Location:Plano, TX
  • Cars:1966 PL520, 1969 Patrol L60, and 1970 240Z

Posted 14 December 2016 - 07:37 PM

Kit was about $30
Labor was about $150

1969 Patrol L60
1965 Patrol L60 (parts provider)
1966 PL520
1970 240Z
1990 300ZX (sold 10/13)


#45 Droski

Droski

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:San Diego
  • Cars:1966 Datsun 520

Posted 14 December 2016 - 07:43 PM

That's not bad. Thanks again everybody for the info. I'll check back with updates.

#46 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 69,430 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 14 December 2016 - 07:52 PM

The truck jerks and loses power Like it wants to go but it hesitates then goes. The engine never shuts off. The gas in the carb leaks when pumping the gas peddle I found that out today without having the engine on. 4 pumps and it begins to leak.

 

Have you replaced the fuel filter?

 

 When you pump the gas the accelerator pump squirts raw gas into the primary barrel. (or should) this gas will wet the throttle plate and if the throttle shaft is worn it might wet the outside as shown.


Posted Image

#47 Droski

Droski

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:San Diego
  • Cars:1966 Datsun 520

Posted 14 December 2016 - 08:47 PM

Yes I replaced the the filter already fuel seems to be traveling okay. Should the fuel filter be packed with gas? I see it about half to 3/4 full most of the time.

#48 Droski

Droski

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:San Diego
  • Cars:1966 Datsun 520

Posted 14 December 2016 - 08:48 PM

Can I rebuild kit help with a worn shaft?

#49 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 69,430 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 15 December 2016 - 07:38 AM

Air in filter is normal. Rebuild kit won't fix the shaft. Not much air can get in and if it did only affects idle, if at all. I'd be more concerned with the throttle plate rubbing and sticking in the bore. 


Posted Image

#50 Droski

Droski

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:San Diego
  • Cars:1966 Datsun 520

Posted 12 August 2017 - 10:32 PM

This problem has been solved! . I had to replace my distributor ! Truck runs like a charm now

#51 datzenmike

datzenmike

    KING RAT

  • User Administrator
  • 69,430 posts
  • Location:Vancouver Island
  • Cars:'74 710 sedan, '76 710. prevoius... '78 620, '71 521, '68 510 new '76 B-210

Posted 13 August 2017 - 06:29 AM

It happens. My 710 had a hesitation just above idle on take offs. Had it since I got it about 5 years ago. Have had the carb off about 6 times now cleaning and adjusting. Better but not perfect. Drove it for the first time in the winter last year. The problem was worse and will backfire out the exhaust which tells me it was ignition not carb. Found the coil tower terminal was carbon tracked. Threw on a spare coil and it's gone completely!


Posted Image

#52 Droski

Droski

    Newbie

  • Members
  • Pip
  • 46 posts
  • Location:San Diego
  • Cars:1966 Datsun 520

Posted 14 August 2017 - 02:01 PM

exactly what mine was doing. Such a simple fix but I tricky problem to diagnose. Definitely learned a lot. Thanks for a lot the help

#53 banzai510(hainz)

banzai510(hainz)

    L motor God

  • Senior Member
  • PipPipPipPipPipPipPipPipPipPip
  • 14,983 posts

Posted 17 August 2017 - 06:52 AM

aqlways keep a spare distributor and carb ready for trouble shooting. Most time its the distributor that worn esp if still running points. (bushing wearm condensor not grounded, eroison on points or point gap( going to electronic makes it last longet but still need to keep a spare in case the dist springs break or dist bushing wear)


Throw on some Weber sidedrafts, Rising Sun hood.... call it good